Start a new topic

Miss Aligned Inserted Photos or Objects

For some reason when I try to insert a photo or other object they initially appear in other areas of the section. Sometimes 6 to 10 photos away from where I'm currently viewing. I have to drag the object to the area I want it in. I always thought the objects would initially appear somewhere in the photo I was viewing at that time then I could insert the text or photo. Also, there are some other strange issues happening. I would think "hope" the only time you would see a specific object or photo would be when you click on that specific photo/view. After experimenting I found that I can not see a photo once I had inserted it using Publisher. All I see is a black frame but no picture. I have tried PNG and JPEG in many different sizes. Also tried the CUPIX logo, same problem. Once I saved it I still could not see the picture in the published tour using Chrome or IE on a windows 10 machine. Only a black square appears. They do show up correctly when using Chrome on an Ipad or Android phone. I can also see the photo I have published thru walls as many as 50 to 75 feet away from where I wanted to view it. I can also see photos on different floors. The only thing I can think of is the objects are inserted into the middle of a section and not a specific photo view. This would make it difficult to work with. This is a nice feature and would use it if I could get it to work properly. Maybe there are some settings or other things I'm not doing incorrectly. Thanks for your help. 


Hi, Mike.


Thanks for reporting those issues to us. Your feedback will help us improve our service.


First of all, virtual objects should initially appear on the spot that you are viewing as you said. It seems like it's a temporary bug and we will be fixing it ASAP. There could be another possible reason for that issue. The tour doesn't have a proper 3D mesh model, and the server can't locate the virtual object to the right position in the tour. The 3D mesh model is foundational to the tour and makes it possible to insert virtual objects. In that case, you can create an occlusion box that works like a real mesh, and insert other virtual objects on it. Here's a video explaining about the Occlusion box. https://www.youtube.com/watch?v=ilGNzcKIUKA&t=48s


For the second issue, we tested it on our computer using the latest Chrome browser, and it worked. Would you please give us a screenshot or a video recording the issue so that we can figure out the cause? So far, we think that's also a bug, and that might be fixed if you refresh the page and delete the cache of the browser. Also, Cupix editing app is optimized in Chrome, so we strongly recommend you to use Chrome when you edit the tours. 


We've checked your tour and found out that you group all three floors in one. To give you a tip, you can add each floor to Section Selector in the 'Publisher' tab. That way you can reduce glitches on adding virtual objects and present your tour more efficiently. 


Best Regards,

Cupix Support

Great info. I'll work on it. 

I took 100 photos in a 3 story house and uploaded in 4 ssections; basement, first floor, second floor and outside. I uploaded all the images and for the most part Cupix did a great job. In the basement though there are 2 images that did not get put into the spots they should be in. They are totally outside of the box that was created for all the other photos. One of them is an image on the stairs between the basement and he first floor. The other is the first photo I took which was in the corner of the main basement room and should have obviously connected into the other images. How can I move images to where they should be and add connections?

. Hi, Mike.


Thanks for writing in. Sometimes, the server couldn't link photos, and the tour ends up with a couple of separated sections. In that case, there are 2 options you can do.


1. Hide photos if they are not necessary for the tour.

2. Manually align them.


The simplest way is to hide the photo by left-clicking it and clicking 'Hide Photos.' You can use this method when the photo is unnecessary for the tour. I think for the image on the stairs is okay to be hidden since you cannot walk through directly to the first floor from the basement. 


The second method is you move the spot that we call a station or section, to the right position. To do that, select the station, and move/rotate it. You can select it by clicking slightly outside of it or simply right-clicking and click 'select enclosing section.' Lock the position after positioning it and connect it to the main section. You can refer to this video(https://www.youtube.com/watch?v=o4h9aopU9To) to learn about how to connect sections. So, for the second photo, you can try this way.


Try it first and share us your tour if you have any problems.


Best Regards,

Cupix Support

All good information. This will be long and hopefully, I don't seem confused. Yes, I have tried all the methods you described. The picture on the stairs can be hidden but it still just doesn't flow well without it. Based on your suggestion, since I had three pictures on the platform between the two flight of stairs, I hid the ones in the corners and connected every other pic and leaving those two disconnected. I still had the same issue which tells me it might not be the position or direction of my camera was pointing that is causing this. If that's true then we DO need a way to select a specific direction you want the camera to point when you click on that picture. Going up and down stairs is a perfect example. I would need to be able to change the direction the camera is viewing for each picture. I can't change the section because that affects many other pictures UNLESS I am not understanding you clearly. Changing the position of the section helped me solve a huge problem in an upstairs area. The tour is a police barracks during a 19-week training school. Both the upstairs and downstairs have two bays on each floor for a total of 4 bays and they are all identical. For some reason, the program got confused with pics in that section. The upstairs back bay overlaid itself on top of the front bay. That caused an impossible situation. I fixed that issue by hiding all the back bay pictures then uploading only the top back bay and grouping them with the front bay. After a few adjustments and linking the two pictures closest to each bay the problem was solved. The other issue I had was inserting an object or picture. I wanted to see if I could upload a single picture in one area, group that picture with the other sections so I could move it around, hide the original picture as I did in the top bay then insert the picture or object into the scene. As a test hopefully that would keep the picture/object inside the area of the THAT single picture and not put it down the hallway. For some reason, I'm not having any luck doing that. Of course, this is a testing process and might not be the ideal way to handle it but at this point, I'm just trying several different ideas to see if I can trick it into submission. Let me do some more testing and I will let you know when I'm out of ideas. Until then send what you can. Thanks for your help. ONE OTHER OBSERVATION: If you think about the camera direction issue we are talking about is seen all the time when taking a tour. While standing in one spot I may have ten pictures connected together in all directions which gives you multiple arrows on the floor to navigate with. If you click on an arrow in any other position other than straight ahead 12 o'clock, your view does not change direction. In other words, if you click on the 6 o'clock arrow in order to back up my view does not flip 180 degrees. This would be something that you could add that would make the tour flow nicely. 

Hi, Mike.


First of all, sorry for the late reply. Here are suggestions that might help you to solve problems that you are struggling with.

The server may have failed to process your photos properly because, as you said, the 4 bays are all identical. The server detects the same features in photos and links them based on that. But the same features in the different photos confuse the server and as a result, the upstairs back bay overlaid itself on top of the front bay. The simplest way to fix it is to upload them separately to different sections. (ex. section 1- bay 1 on the 1st floor, section 2 - bay 2 on the 1st floor, section 3- bay 3 on the 2nd floor, section 4 on the 2nd floor) Regarding the change of the camera viewpoint direction, unfortunately, you are not able to change the direction of camera position for each picture. However, you can rotate each section and a section that consists of one photo. The server automatically aligns the orientation and location of each photo in the section, and once they are processed together, you can't change each photo in that section individually. 


The newly added, or more exactly replaced, picture in the area isn't fully integrated with other sections even though, you group it and connect it to other sections. The image itself seems to be connected but the 3D data laid under the image is not linked to other sections, and that's why the object you added didn't appear in the other section. We also have no idea how to fix that situation, but the only thing we can suggest is to create a whole new tour dividing photos into 4 sections as we aforementioned.


For the last feedback, we provide an immersive 3D tour that makes users feel as real as being there, and if the view flips 180-degree in a sudden when they click on the 6 o'clock arrow, the transition could be distracting. If you imagine yourself view the tour with a VR headset, then this way of transition makes sense. But our opinion is worth discussing when it comes to the web view.


We do appreciate your great interest in Cupix and hope to hear from you.


Best Regards, 

Cupix Support

Login or Signup to post a comment